# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[?[A-Za-z]+?:\\/\\/.+?:)(.*?)(@.+?)/$1*****$3/g;t' <<< "http://user1:password1@localhost:8080
http://user2@localhost:8082
[http://user1:password1@localhost:8080,http://user2@localhost:8082,http://localhost:8083]
[http://user1:password1@localhost:8080,http://user2:password2@localhost:8082,http://localhost:8083]"