$re = '/(\[?[A-Za-z]+?:\/\/.+?:)(.*?)(@.+?)/';
$str = 'http://user1:password1@localhost:8080
http://user2@localhost:8082
[http://user1:password1@localhost:8080,http://user2@localhost:8082,http://localhost:8083]
[http://user1:password1@localhost:8080,http://user2:password2@localhost:8082,http://localhost:8083]';
$subst = "$1*****$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;