using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[?[A-Za-z]+?:\/\/.+?:)(.*?)(@.+?)";
string substitution = @"$1*****$3";
string input = @"http://user1:password1@localhost:8080
http://user2@localhost:8082
[http://user1:password1@localhost:8080,http://user2@localhost:8082,http://localhost:8083]
[http://user1:password1@localhost:8080,http://user2:password2@localhost:8082,http://localhost:8083]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}