const regex = /(\[?[A-Za-z]+?:\/\/.+?:)(.*?)(@.+?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[?[A-Za-z]+?:\\\/\\\/.+?:)(.*?)(@.+?)', 'g')
const str = `http://user1:password1@localhost:8080
http://user2@localhost:8082
[http://user1:password1@localhost:8080,http://user2@localhost:8082,http://localhost:8083]
[http://user1:password1@localhost:8080,http://user2:password2@localhost:8082,http://localhost:8083]`;
const subst = `$1*****$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);