use strict;
my $str = 'http://user1:password1@localhost:8080
http://user2@localhost:8082
[http://user1:password1@localhost:8080,http://user2@localhost:8082,http://localhost:8083]
[http://user1:password1@localhost:8080,http://user2:password2@localhost:8082,http://localhost:8083]';
my $regex = qr/(\[?[A-Za-z]+?:\/\/.+?:)(.*?)(@.+?)/p;
my $subst = '$1*****$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";