#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?uis)<(a)[^>]*?(?!match)[^>]+>[^<]+<\/\1>"
Local $sString = "текст 1" & @CRLF & _
"<a class="btn" href="https://site.ru/">Ссылка1</a>" & @CRLF & _
"текст 2" & @CRLF & _
"<a class="btn" href="https://match.com">Ссылка2</a>" & @CRLF & _
"текст 3" & @CRLF & _
"<a class="btn" href="https://fall.com/">Ссылка3</a>" & @CRLF & _
"текст 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")