using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(a)[^>]*?(?!match)[^>]+>[^<]+<\/\1>";
string input = @"текст 1
<a class=""btn"" href=""https://site.ru/"">Ссылка1</a>
текст 2
<a class=""btn"" href=""https://match.com"">Ссылка2</a>
текст 3
<a class=""btn"" href=""https://fall.com/"">Ссылка3</a>
текст 4";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}