$re = '~<(a)[^>]*?(?!match)[^>]+>[^<]+<\/\1>~uis';
$str = 'текст 1
<a class="btn" href="https://site.ru/">Ссылка1</a>
текст 2
<a class="btn" href="https://match.com">Ссылка2</a>
текст 3
<a class="btn" href="https://fall.com/">Ссылка3</a>
текст 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);