const regex = new RegExp('<(a)[^>]*?(?!match)[^>]+>[^<]+<\\/\\1>', 'guis')
const str = `текст 1
<a class="btn" href="https://site.ru/">Ссылка1</a>
текст 2
<a class="btn" href="https://match.com">Ссылка2</a>
текст 3
<a class="btn" href="https://fall.com/">Ссылка3</a>
текст 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}