# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^"|"$|";+"|";\d+;"|";|;")|"/$1/gm;t' <<< "\"aa\";\"bb\";\"cc\";\"dd\";\"ee\"
\"aa\";\"bb\";\"c \"cc\" c\";\"dd\";\"ee\"
\"aa\";;\"cc\";\"dd\";\"ee\"
\"aa\";55;\"cc\";\"dd\";\"ee\"
\"aa\";\"77\";55;55;\"bb\";\"cc\"
\"aa\";\"77\";5\"dd\"5;55;\"bb\";\"cc\"
\"aa\";\"77\";55;55;\"bb\";\"cc\"
\"aa\";77;55;55;\"bb\";\"cc\"
"