# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\"|\"$|\";+\"|\";\d+;\"|\";|;\")|\""
test_str = ("\"aa\";\"bb\";\"cc\";\"dd\";\"ee\"\n"
"\"aa\";\"bb\";\"c \"cc\" c\";\"dd\";\"ee\"\n"
"\"aa\";;\"cc\";\"dd\";\"ee\"\n"
"\"aa\";55;\"cc\";\"dd\";\"ee\"\n"
"\"aa\";\"77\";55;55;\"bb\";\"cc\"\n"
"\"aa\";\"77\";5\"dd\"5;55;\"bb\";\"cc\"\n"
"\"aa\";\"77\";55;55;\"bb\";\"cc\"\n"
"\"aa\";77;55;55;\"bb\";\"cc\"\n\n\n\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.