import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\"|\"$|\";+\"|\";\\d+;\"|\";|;\")|\"";
final String string = "\"aa\";\"bb\";\"cc\";\"dd\";\"ee\"\n"
+ "\"aa\";\"bb\";\"c \"cc\" c\";\"dd\";\"ee\"\n"
+ "\"aa\";;\"cc\";\"dd\";\"ee\"\n"
+ "\"aa\";55;\"cc\";\"dd\";\"ee\"\n"
+ "\"aa\";\"77\";55;55;\"bb\";\"cc\"\n"
+ "\"aa\";\"77\";5\"dd\"5;55;\"bb\";\"cc\"\n"
+ "\"aa\";\"77\";55;55;\"bb\";\"cc\"\n"
+ "\"aa\";77;55;55;\"bb\";\"cc\"\n\n\n\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}