$re = '/(^"|"$|";+"|";\d+;"|";|;")|"/m';
$str = '"aa";"bb";"cc";"dd";"ee"
"aa";"bb";"c "cc" c";"dd";"ee"
"aa";;"cc";"dd";"ee"
"aa";55;"cc";"dd";"ee"
"aa";"77";55;55;"bb";"cc"
"aa";"77";5"dd"5;55;"bb";"cc"
"aa";"77";55;55;"bb";"cc"
"aa";77;55;55;"bb";"cc"
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;