import Foundation
let pattern = #"(^"|"$|";+"|";\d+;"|";|;")|""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"aa";"bb";"cc";"dd";"ee"
"aa";"bb";"c "cc" c";"dd";"ee"
"aa";;"cc";"dd";"ee"
"aa";55;"cc";"dd";"ee"
"aa";"77";55;55;"bb";"cc"
"aa";"77";5"dd"5;55;"bb";"cc"
"aa";"77";55;55;"bb";"cc"
"aa";77;55;55;"bb";"cc"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)