using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)\/(?<mnemonic>.+)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$";
string input = @"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Obam_9781524763138_die_all_r1.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}