re = /^(.*)\/(?<mnemonic>.+)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$/m
str = 'Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Obam_9781524763138_die_all_r1.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end