$re = '/^(.*)\/(?<mnemonic>.+)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$/m';
$str = 'Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Obam_9781524763138_die_all_r1.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);