// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*)\/(?<mnemonic>.+)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$").unwrap();
let string = "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Obam_9781524763138_die_all_r1.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}