package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)\/(?<mnemonic>.+)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$`)
var str = `Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Obam_9781524763138_die_all_r1.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}