package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z]+\s\w+\s\d++\w`)
var str = `Adam has 100 friends. Bill has 23 friends. Cindy has 5 friends. Chapter is 23A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}