$re = '/[A-Za-z]+\s\w+\s\d++\w/m';
$str = 'Adam has 100 friends. Bill has 23 friends. Cindy has 5 friends. Chapter is 23A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);