const regex = /[A-Za-z]+\s\w+\s\d++\w/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z]+\\s\\w+\\s\\d++\\w', 'gm')
const str = `Adam has 100 friends. Bill has 23 friends. Cindy has 5 friends. Chapter is 23A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}