re = /[A-Za-z]+\s\w+\s\d++\w/m
str = 'Adam has 100 friends. Bill has 23 friends. Cindy has 5 friends. Chapter is 23A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end