// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Za-z]+\s\w+\s\d++\w").unwrap();
let string = "Adam has 100 friends. Bill has 23 friends. Cindy has 5 friends. Chapter is 23A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}