#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b\d(?: ?\d){7}(?= *[,;.]|$)"
Local $sString = "12345678,12345678,12345678" & @CRLF & _
"12345678.12345678,12345678;12345678" & @CRLF & _
"12345678 , 12345678 . 12345678 ; 12345678" & @CRLF & _
"1234 5678 .12 345678, 123 45678 ;12 3456 78"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)