import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d(?: ?\\d){7}(?= *[,;.]|$)";
final String string = "12345678,12345678,12345678\n"
+ "12345678.12345678,12345678;12345678\n"
+ "12345678 , 12345678 . 12345678 ; 12345678\n"
+ "1234 5678 .12 345678, 123 45678 ;12 3456 78";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}