re = /\b\d(?: ?\d){7}(?= *[,;.]|$)/m
str = '12345678,12345678,12345678
12345678.12345678,12345678;12345678
12345678 , 12345678 . 12345678 ; 12345678
1234 5678 .12 345678, 123 45678 ;12 3456 78'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result