import re
regex = re.compile(r"\b\d(?: ?\d){7}(?= *[,;.]|$)", flags=re.MULTILINE)
test_str = ("12345678,12345678,12345678\n"
"12345678.12345678,12345678;12345678\n"
"12345678 , 12345678 . 12345678 ; 12345678\n"
"1234 5678 .12 345678, 123 45678 ;12 3456 78")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)