const regex = /\b\d(?: ?\d){7}(?= *[,;.]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d(?: ?\\d){7}(?= *[,;.]|$)', 'gm')
const str = `12345678,12345678,12345678
12345678.12345678,12345678;12345678
12345678 , 12345678 . 12345678 ; 12345678
1234 5678 .12 345678, 123 45678 ;12 3456 78`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);