using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(0?\d|1[01])(?=:[0-5]?\d\s*PM)";
string input = @"00:23PM
03:23PM
11:23PM
12:23PM
13:45PM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}