use strict;
my $str = '00:23PM
03:23PM
11:23PM
12:23PM
13:45PM';
my $regex = qr/(?<!\d)(0?\d|1[01])(?=:[0-5]?\d\s*PM)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}