import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)(0?\\d|1[01])(?=:[0-5]?\\d\\s*PM)";
final String string = "00:23PM\n"
+ "03:23PM\n"
+ "11:23PM\n\n"
+ "12:23PM\n"
+ "13:45PM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}