re = /(?<!\d)(0?\d|1[01])(?=:[0-5]?\d\s*PM)/m
str = '00:23PM
03:23PM
11:23PM
12:23PM
13:45PM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end