$re = '/(?<!\d)(0?\d|1[01])(?=:[0-5]?\d\s*PM)/m';
$str = '00:23PM
03:23PM
11:23PM
12:23PM
13:45PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);