using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<(style)(?:\s+(?=((?:""[\S\s]*?""|'[\S\s]*?'|(?:(?!\/>)[^>])?)+))\2)?\s*>)([\S\s]*?)<\/\1\s*>";
string input = @"const str1 = '<style> div { color: red; } a { color: green; } </style>hello<div></div><div><a>hello</a></div>'
const str2 = '<style> div { color: red; } div > a { color: green; } </style>hello<div></div><div><a>hello</a></div>'
const regex = /<style[^>]*>([^>]*?)<\/style>/g
const matches1 = str1.match(regex) // returns a match
const matches2 = str2.match(regex) // does NOT return a match
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}