const regex = /(?:<(style)(?:\s+(?=((?:"[\S\s]*?"|'[\S\s]*?'|(?:(?!\/>)[^>])?)+))\2)?\s*>)([\S\s]*?)<\/\1\s*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<(style)(?:\\s+(?=((?:"[\\S\\s]*?"|\'[\\S\\s]*?\'|(?:(?!\\\/>)[^>])?)+))\\2)?\\s*>)([\\S\\s]*?)<\\\/\\1\\s*>', 'g')
const str = `const str1 = '<style> div { color: red; } a { color: green; } </style>hello<div></div><div><a>hello</a></div>'
const str2 = '<style> div { color: red; } div > a { color: green; } </style>hello<div></div><div><a>hello</a></div>'
const regex = /<style[^>]*>([^>]*?)<\\/style>/g
const matches1 = str1.match(regex) // returns a match
const matches2 = str2.match(regex) // does NOT return a match
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}