$re = '/(?:<(style)(?:\s+(?=((?:"[\S\s]*?"|\'[\S\s]*?\'|(?:(?!\/>)[^>])?)+))\2)?\s*>)([\S\s]*?)<\/\1\s*>/';
$str = 'const str1 = \'<style> div { color: red; } a { color: green; } </style>hello<div></div><div><a>hello</a></div>\'
const str2 = \'<style> div { color: red; } div > a { color: green; } </style>hello<div></div><div><a>hello</a></div>\'
const regex = /<style[^>]*>([^>]*?)<\\/style>/g
const matches1 = str1.match(regex) // returns a match
const matches2 = str2.match(regex) // does NOT return a match
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);