use strict;
my $str = 'const str1 = \'<style> div { color: red; } a { color: green; } </style>hello<div></div><div><a>hello</a></div>\'
const str2 = \'<style> div { color: red; } div > a { color: green; } </style>hello<div></div><div><a>hello</a></div>\'
const regex = /<style[^>]*>([^>]*?)<\\/style>/g
const matches1 = str1.match(regex) // returns a match
const matches2 = str2.match(regex) // does NOT return a match
';
my $regex = qr/(?:<(style)(?:\s+(?=((?:"[\S\s]*?"|'[\S\s]*?'|(?:(?!\/>)[^>])?)+))\2)?\s*>)([\S\s]*?)<\/\1\s*>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}