import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<(style)(?:\\s+(?=((?:\"[\\S\\s]*?\"|'[\\S\\s]*?'|(?:(?!\\/>)[^>])?)+))\\2)?\\s*>)([\\S\\s]*?)<\\/\\1\\s*>";
final String string = "const str1 = '<style> div { color: red; } a { color: green; } </style>hello<div></div><div><a>hello</a></div>'\n"
+ "const str2 = '<style> div { color: red; } div > a { color: green; } </style>hello<div></div><div><a>hello</a></div>'\n\n"
+ "const regex = /<style[^>]*>([^>]*?)<\\/style>/g\n\n"
+ "const matches1 = str1.match(regex) // returns a match\n"
+ "const matches2 = str2.match(regex) // does NOT return a match\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}