#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((http|https):\/\/)?www\.)?yuque\.com\/([a-zA-Z\=]*)\/([a-zA-Z]*)\/([a-zA-Z]*)\/?"
Local $sString = "https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc/" & @CRLF & _
"https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc" & @CRLF & _
"http://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc" & @CRLF & _
"www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc" & @CRLF & _
"yuque.com/cheche=xsrvr/sbzuyb/ygzghc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")