using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((http|https):\/\/)?www\.)?yuque\.com\/([a-zA-Z\=]*)\/([a-zA-Z]*)\/([a-zA-Z]*)\/?";
string input = @"https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc/
https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
http://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
yuque.com/cheche=xsrvr/sbzuyb/ygzghc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}