import Foundation
let pattern = #"(((http|https):\/\/)?www\.)?yuque\.com\/([a-zA-Z\=]*)\/([a-zA-Z]*)\/([a-zA-Z]*)\/?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc/
https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
http://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
yuque.com/cheche=xsrvr/sbzuyb/ygzghc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)