# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(,\s*\"attr\" *: *\".*\"|(?=\s*\}))|(\s*\"attr\" *: *\".*\"(,|(?=\s*\})))//g;t' <<< "{\"attr\": \"singlematch\"}
{
\"attr\": \"MYVALUE\",
\"anotherAttr0\": \"foobar\",
\"attr\": \"MYVALUE2\",
\"attr\":\"witthourspace\",
\"attr\": 23,
\"anotherAttr1\": false,
\"attr\": \"notin arow\",
\"anotherAttr2\": \"300\",
\"attr\": \"MYVALUE3\"
}
{\"attr\":\"single match no space\"}
{ \"attr\" : \"Weird spacing\"}
{
\"attr\": \"Simple json isn't collapsed but, that's fine\"
}
{
\"attr2\": \"bob\",
}
{}
{
\"a\":1,
\"b\":2,
}
{
\"attr\": \"fred\",
\"attr\": \"Joe\",
\"attr\": \"Hey!\"
}
{
\"a\":2,
\"attr\":\"test\",
\"bob\":2,
}"