const regex = /(,\s*\"attr\" *: *\".*\"|(?=\s*\}))|(\s*\"attr\" *: *\".*\"(,|(?=\s*\})))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(,\\s*\\"attr\\" *: *\\".*\\"|(?=\\s*\\}))|(\\s*\\"attr\\" *: *\\".*\\"(,|(?=\\s*\\})))', 'g')
const str = `{"attr": "singlematch"}
{
"attr": "MYVALUE",
"anotherAttr0": "foobar",
"attr": "MYVALUE2",
"attr":"witthourspace",
"attr": 23,
"anotherAttr1": false,
"attr": "notin arow",
"anotherAttr2": "300",
"attr": "MYVALUE3"
}
{"attr":"single match no space"}
{ "attr" : "Weird spacing"}
{
"attr": "Simple json isn't collapsed but, that's fine"
}
{
"attr2": "bob",
}
{}
{
"a":1,
"b":2,
}
{
"attr": "fred",
"attr": "Joe",
"attr": "Hey!"
}
{
"a":2,
"attr":"test",
"bob":2,
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);