# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(,\s*\"attr\" *: *\".*\"|(?=\s*\}))|(\s*\"attr\" *: *\".*\"(,|(?=\s*\})))"
test_str = ("{\"attr\": \"singlematch\"}\n"
"{\n"
" \"attr\": \"MYVALUE\",\n"
" \"anotherAttr0\": \"foobar\",\n"
" \"attr\": \"MYVALUE2\",\n"
" \"attr\":\"witthourspace\",\n"
" \"attr\": 23,\n"
" \"anotherAttr1\": false,\n"
" \"attr\": \"notin arow\",\n"
" \"anotherAttr2\": \"300\",\n"
" \"attr\": \"MYVALUE3\"\n"
"}\n"
"{\"attr\":\"single match no space\"}\n"
"{ \"attr\" : \"Weird spacing\"}\n"
"{\n"
" \"attr\": \"Simple json isn't collapsed but, that's fine\"\n"
"}\n"
"{\n"
" \"attr2\": \"bob\",\n"
"}\n"
"{}\n"
"{\n"
"\"a\":1,\n"
"\"b\":2,\n"
"}\n"
"{\n"
" \"attr\": \"fred\",\n"
" \"attr\": \"Joe\",\n"
" \"attr\": \"Hey!\"\n"
"}\n"
"{\n"
"\"a\":2,\n"
" \"attr\":\"test\",\n"
" \"bob\":2,\n"
"}")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.