import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(,\\s*\\\"attr\\\" *: *\\\".*\\\"|(?=\\s*\\}))|(\\s*\\\"attr\\\" *: *\\\".*\\\"(,|(?=\\s*\\})))";
final String string = "{\"attr\": \"singlematch\"}\n"
+ "{\n"
+ " \"attr\": \"MYVALUE\",\n"
+ " \"anotherAttr0\": \"foobar\",\n"
+ " \"attr\": \"MYVALUE2\",\n"
+ " \"attr\":\"witthourspace\",\n"
+ " \"attr\": 23,\n"
+ " \"anotherAttr1\": false,\n"
+ " \"attr\": \"notin arow\",\n"
+ " \"anotherAttr2\": \"300\",\n"
+ " \"attr\": \"MYVALUE3\"\n"
+ "}\n"
+ "{\"attr\":\"single match no space\"}\n"
+ "{ \"attr\" : \"Weird spacing\"}\n"
+ "{\n"
+ " \"attr\": \"Simple json isn't collapsed but, that's fine\"\n"
+ "}\n"
+ "{\n"
+ " \"attr2\": \"bob\",\n"
+ "}\n"
+ "{}\n"
+ "{\n"
+ "\"a\":1,\n"
+ "\"b\":2,\n"
+ "}\n"
+ "{\n"
+ " \"attr\": \"fred\",\n"
+ " \"attr\": \"Joe\",\n"
+ " \"attr\": \"Hey!\"\n"
+ "}\n"
+ "{\n"
+ "\"a\":2,\n"
+ " \"attr\":\"test\",\n"
+ " \"bob\":2,\n"
+ "}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}