using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,\s*\""attr\"" *: *\"".*\""|(?=\s*\}))|(\s*\""attr\"" *: *\"".*\""(,|(?=\s*\})))";
string substitution = @"";
string input = @"{""attr"": ""singlematch""}
{
""attr"": ""MYVALUE"",
""anotherAttr0"": ""foobar"",
""attr"": ""MYVALUE2"",
""attr"":""witthourspace"",
""attr"": 23,
""anotherAttr1"": false,
""attr"": ""notin arow"",
""anotherAttr2"": ""300"",
""attr"": ""MYVALUE3""
}
{""attr"":""single match no space""}
{ ""attr"" : ""Weird spacing""}
{
""attr"": ""Simple json isn't collapsed but, that's fine""
}
{
""attr2"": ""bob"",
}
{}
{
""a"":1,
""b"":2,
}
{
""attr"": ""fred"",
""attr"": ""Joe"",
""attr"": ""Hey!""
}
{
""a"":2,
""attr"":""test"",
""bob"":2,
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}