using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<h(?:3|4|5).*?<\/h(?:3|4|5)>)((.*?\n)*?)(<p>.*?<\/p>)";
string input = @"<h2>header 2</h2>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок без нака вопроса</h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок со знаком вопроса? </h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}