import Foundation
let pattern = #"(<h(?:3|4|5).*?<\/h(?:3|4|5)>)((.*?\n)*?)(<p>.*?<\/p>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<h2>header 2</h2>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок без нака вопроса</h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок со знаком вопроса? </h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}