$re = '~(<h(?:3|4|5).*?<\/h(?:3|4|5)>)((.*?\n)*?)(<p>.*?<\/p>)~is';
$str = '<h2>header 2</h2>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок без нака вопроса</h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок со знаком вопроса? </h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);